Sunday, November 24, 2013

Revit 2014 User Interface is Forgetful

I didn't notice this when 2014 was first released but since the last two web updates Revit seems to be forgetful about the Project Browser and Properties Palette status. I find that I can work for awhile, close Revit and return to find the palette and browser aren't open. When I examine their settings via View ribbon > User Interface the check marks indicate that Revit "thinks" they are open but they aren't "there". If I "close" them by un-checking and then check them again they come back.

I do find it is less forgetful if I allow the Recent Files list to open. There is an option to disable it in the Options Dialog (User Interface section), "Enable Recent files page at startup". If I disable it however I find that the palette and browser linger on screen when I close projects and families which gives the appearance that the project is still open because it will still display information that is part of the last project.

I've visited a few clients suffering with this and have heard from friends as well. It seems related to the new dockable browser API and it's messing with a couple external applications too apparently. If you are encountering this, you aren't alone. Hopefully they'll sort it out and issue another web update or perhaps a Hotfix to sort it out sooner than later.


Dave said...

Since Ctrl-1 is already the Keyboard Shortcut to toggle the Properties dialog, I've assigned Ctrl-2 to the Project Browser.
That way, if (when) we see the problem you're talking about, we can just hit Ctrl-1, Ctrl-1, Ctrl-2, Ctrl-2 to go through the Close/Open sequence.
Doesn't come close to fixing the problem, but it does make it easy to recover from.

seandburke said...

We've disabled Recent Files, to prevent accidental opening of the Central file. We even have an API tool to replace the Recent Files with a My Favorites tool. And now, because of this bug, let's call it what it really is, I may have to reconsider that decision.

Jimi Clarke said...


Does anyone know if there is a solution to this yet (2015?) please?

Jimi Clarke
BIM Manager London UK